Umstellung auf PHP 8.1

Mein Hoster goneo wird aus Sicherheitsgründen PHP 7.4 ab Februar 2023 nicht mehr bereitstellen. Das führt dazu, dass ich nach und nach alle Inhalte auf dem Server (also nicht nur diesen Blog) auf PHP 8.1 umstellen bzw. deren Kompatibilität prüfen muss.

Php 8.1

Das ist richtig und wichtig, aber das ist auch etwas, wovor man sich mit Freude ein bisschen drückt. Gerade bei WordPress machen einige Themes und ältere Plugins gerne mal Probleme. So war es auch.

Einige veraltete Plugins mussten weichen, einige Custom-Funktionen angepasst und einige Themenfeatures umgebaut werden. Alles nichts Wildes, aber dennoch zeitraubend. Dem ersten Eindruck nach hat alles geklappt.

Als Besucher dieses Blogs sollten die Anpassungen kaum auffallen. Einzig das Plugin für die datenschutzkonformen Embeds habe ich ganz ausgetauscht. Hier kommt nun Embed Privacy zum Einsatz (siehe Beispiel nachfolgend).

Hier klicken, um den Inhalt von Twitter anzuzeigen.
Erfahre mehr in der Datenschutzerklärung von Twitter.

Sollten Probleme auffallen, dürfen diese gerne gemeldet werden.

Schreibe einen Kommentar    

Deine E-Mail-Adresse wird nicht veröffentlicht. Durch das Absenden eines Kommentars stimmst du der Speicherung deiner Angaben gemäß der Datenschutzerklärung zu.

Du bist hier: FLIP.de / Coding & Publishing / ...